Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2182 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Nag upstream maintainers to release final versions of our dependencies.

Reported by: jorge.vargas Owned by: mramm
Priority: low Milestone: 2.1rc1
Component: TurboGears Version: trunk
Severity: major Keywords:
Cc:

Description (last modified by jorge.vargas) (diff)

In order to get ourselves in shape for TG2.0final we need to ask several upstream packages to do final releases of their packages.

Goals

  1. Have no svn dependencies
  2. Have no alpha or beta dependencies
  3. Have only final dependencies

The goals are progressive and the more the merrier. Having half of goals #2 complete is a good milestone, since we have aprox. 1 month.

Attachments

b6requirements.txt Download (1.3 KB) - added by jorge.vargas 10 years ago.
full requirements list

Change History

comment:1 Changed 10 years ago by jorge.vargas

  • Description modified (diff)

formatting

comment:2 follow-up: ↓ 4 Changed 10 years ago by percious

which packages do we need to nag about?

comment:3 Changed 10 years ago by mramm

Dev packages in our current index:

  • peak.rules (probably not going to happen)

Packages which probably have new releases, but which are not up to date in the index:

Packages we should probably remove:

  • tg.ext.repoze.who-0.1dev-r26.tar.gz
  • tg.ext.silverplate-0.1rc3-r47.tar.gz

comment:4 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 10 years ago by jorge.vargas

Replying to percious:

which packages do we need to nag about?

using a fully test enable tg2 venv (all templating engines) and pip freeze these are the packages without a release.

PEAK-Rules==0.5a1.dev-r2582
Pylons==0.9.7rc6
WebFlash==0.1a8
chameleon.core==1.0b17
chameleon.genshi==1.0b2
lxml==2.2beta2
pytz==2009a
repoze.tm2==1.0a4
repoze.what-pylons==1.0b2
repoze.what-quickstart==1.0rc4
repoze.what.plugins.sql==1.0rc1
repoze.who-friendlyform==1.0b1
repoze.who.plugins.sa==1.0rc1
transaction==1.0a1

Changed 10 years ago by jorge.vargas

full requirements list

comment:5 in reply to: ↑ 4 Changed 10 years ago by Gustavo

Replying to jorge.vargas:

repoze.what-pylons==1.0b2
repoze.what-quickstart==1.0rc4
repoze.what.plugins.sql==1.0rc1
repoze.who-friendlyform==1.0b1
repoze.who.plugins.sa==1.0rc1
  • repoze.what-quickstart, repoze.what.plugins.sql, repoze.what-pylons and repoze.who.plugins.sa have all release candidates and are pretty stable. Also, I expect that the current RCs are the last ones.
  • repoze.who-friendlyform won't have a final release before TG2 final. repoze.what-quickstart uses a repoze.who plugin defined in this package, which is pretty stable and its API is not going to change, but the whole package is far from even getting a RC.

comment:6 Changed 10 years ago by mramm

  • Priority changed from high to low

peak rules is not going to have a release. and I think chamelion.core and chamelion.genshi, and lxml are far enough out of the standard use pattern that I don't mind about them.

Pytz is also not a major concern. I'll check in on transaction since it seems like it's long been stable but has not had a 1.0 release. ;)

comment:7 Changed 10 years ago by mramm

  • Milestone changed from 2.0rc1 to 2.0rc2

comment:8 Changed 10 years ago by percious

  • Milestone changed from 2.1a2 to 2.1

comment:9 Changed 9 years ago by percious

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from 2.1 to 2.1rc1
Note: See TracTickets for help on using tickets.