Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2223 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Quickstarted applications don't follow PEPs 8 and 257

Reported by: Gustavo Owned by: Gustavo
Priority: highest Milestone: 2.0rc1
Component: Quickstart Templates Version: trunk
Severity: major Keywords:
Cc:

Description

Quickstarted applications don't follow  PEP 8 and  PEP 257, so every time it generates an application, I have to go through the boring/repetitive process of making it comply with both standards.

Change History

comment:1 Changed 10 years ago by Gustavo

  • Status changed from new to assigned

comment:2 Changed 10 years ago by chrisz

The quickstarted Python files should also contain an utf-8 encoding hint in the first line. I also need to add this manually every time.

comment:3 follow-up: ↓ 4 Changed 10 years ago by mramm

  • Priority changed from high to highest

If the quickstart is going to change in any way, it must be done very, very soon.

If there's a list of things that need to be done, we can make this happen, otherwise it will have to be deffered to 2.1 and the PEP 8 thugs will be free to taunt us as much as they want.

comment:4 in reply to: ↑ 3 Changed 10 years ago by Gustavo

  • Status changed from assigned to closed
  • Resolution set to fixed

Replying to mramm:

If the quickstart is going to change in any way, it must be done very, very soon.

OK, done in [6453].

Note: See TracTickets for help on using tickets.