Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2232 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

possible content-type bug

Reported by: jorge.vargas Owned by: precious
Priority: normal Milestone: 2.0rc1
Component: TurboGears Version: trunk
Severity: normal Keywords:
Cc:

Description

This is going to be hard to reproduce but when doing hg pull for codemill I'm getting the following traceback (in the server as weberror isn't present)

Exception happened during processing of request from ('127.0.0.1', 58356)
Traceback (most recent call last):
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/paste/httpserver.py", line 1062, in process_request_in_thread
    self.finish_request(request, client_address)
  File "/usr/local/lib/python2.5/SocketServer.py", line 254, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/local/lib/python2.5/SocketServer.py", line 522, in __init__
    self.handle()
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/paste/httpserver.py", line 436, in handle
    BaseHTTPRequestHandler.handle(self)
  File "/usr/local/lib/python2.5/BaseHTTPServer.py", line 316, in handle
    self.handle_one_request()
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/paste/httpserver.py", line 431, in handle_one_request
    self.wsgi_execute()
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/paste/httpserver.py", line 287, in wsgi_execute
    self.wsgi_start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/paste/cascade.py", line 130, in __call__
    return self.apps[-1](environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/paste/registry.py", line 350, in __call__
    app_iter = self.application(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/middleware.py", line 210, in __call__
    self.app, environ, catch_exc_info=True)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/util.py", line 94, in call_wsgi_application
    app_iter = application(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/weberror/evalexception.py", line 235, in __call__
    return self.respond(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/weberror/evalexception.py", line 418, in respond
    return self.application(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/src/svn.turbogears.org/tg/configuration.py", line 613, in wrapper
    return app(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/src/svn.turbogears.org/tg/configuration.py", line 516, in remover
    return app(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/repoze/tm/__init__.py", line 19, in __call__
    result = self.application(environ, save_status_and_headers)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/repoze/who/middleware.py", line 107, in __call__
    app_iter = app(environ, wrapper.wrap_start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/tw/core/middleware.py", line 36, in __call__
    return self.wsgi_app(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/tw/core/middleware.py", line 59, in wsgi_app
    resp = req.get_response(self.application)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/webob/__init__.py", line 1325, in get_response
    application, catch_exc_info=False)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/webob/__init__.py", line 1293, in call_application
    app_iter = application(self.environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/tw/core/resource_injector.py", line 67, in _injector
    resp = req.get_response(app)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/webob/__init__.py", line 1325, in get_response
    application, catch_exc_info=False)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/webob/__init__.py", line 1293, in call_application
    app_iter = application(self.environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/beaker/middleware.py", line 81, in __call__
    return self.app(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/beaker/middleware.py", line 160, in __call__
    return self.wrap_app(environ, session_start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/routes/middleware.py", line 130, in __call__
    response = self.app(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/wsgiapp.py", line 126, in __call__
    response = self.dispatch(controller, environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/wsgiapp.py", line 321, in dispatch
    return controller(environ, start_response)
  File "/home/mae/webapps/tgext_codemill/src/codemill/CodeMill/codemill/lib/base.py", line 36, in __call__
    return TGController.__call__(self, environ, start_response)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/controllers/core.py", line 221, in __call__
    response = self._dispatch_call()
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/controllers/core.py", line 172, in _dispatch_call
    response = self._inspect_call(func)
  File "/home/mae/webapps/tgext_codemill/lib/python2.5/site-packages/pylons/controllers/core.py", line 107, in _inspect_call
    result = self._perform_call(func, args)
  File "/home/mae/webapps/tgext_codemill/src/svn.turbogears.org/tg/controllers.py", line 735, in _perform_call
    self, controller, params, remainder=remainder)
  File "/home/mae/webapps/tgext_codemill/src/svn.turbogears.org/tg/controllers.py", line 144, in _perform_call
    response = self._render_response(controller, output)
  File "/home/mae/webapps/tgext_codemill/src/svn.turbogears.org/tg/controllers.py", line 257, in _render_response
    controller.decoration.lookup_template_engine(pylons.request)
  File "/home/mae/webapps/tgext_codemill/src/svn.turbogears.org/tg/decorators.py", line 132, in lookup_template_engine
    engine, template, exclude_names = self.engines[content_type]
KeyError: ''

Change History

comment:1 Changed 10 years ago by jorge.vargas

I'm not able to reproduce this with current trunk yet, but a problem is still there.

comment:2 Changed 10 years ago by mramm

Hmm, can you reopen this when you get some more specific info, or when you can produce a project that we can reproduce the error with. ;)

comment:3 Changed 10 years ago by mramm

  • Status changed from new to closed
  • Resolution set to worksforme

comment:4 Changed 10 years ago by jorge.vargas

#2351 is another manifestation of this.

Note: See TracTickets for help on using tickets.