Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2233 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

TG2 installation always crashes on the virtualenv step

Reported by: Artem Owned by: faide
Priority: normal Milestone: 2.0rc1
Component: Installation Version: 2.0b5
Severity: blocker Keywords: crash, installation, first use
Cc:

Description

I am not 100% sure how to fill milestone/version fields. Please, correct if I am wrong

Follow the official setup instructions from  http://www.turbogears.org/2.0/docs/main/DownloadInstall.html . Python is always crashing on the "virtualenv --no-site-packages tg2env" step. I guess the problem is not in TG2 itself, but that is a huge show stopper for anybody on Vista anyway. So it has to be either fixed or workaround has to be present.

*More details about my environment*

  1. Vista Enterprise (close to Vista Ultimate)
  2. Account of a local administrator (not a built-in admin)
  3. User Access Control disabled
  4. Trying to install version that is available on Feb 21 2009 (2.0 beta 5 I guess)

*What is shown in the command line*


C:\>virtualenv --no-site-packages tg2env New python executable in tg2env\Scripts\python.exe Installing setuptools..............


*What is shown in the Windows crash prompt (copy pasted by Ctrl-C/Ctrl-V)*


[Window Title] Microsoft Windows

[Main Instruction] python.exe has stopped working

[Content] Windows can check online for a solution to the problem.

[] Hide problem details [Check online for a solution and close the program] [Close the program]

Problem signature:

Problem Event Name: APPCRASH Application Name: python.exe Application Version: 0.0.0.0 Application Timestamp: 4937fccd Fault Module Name: _hashlib.pyd Fault Module Version: 0.0.0.0 Fault Module Timestamp: 4937fd40 Exception Code: c0000005 Exception Offset: 00005d16 OS Version: 6.0.6001.2.1.0.256.4 Locale ID: 1033 Additional Information 1: fd00 Additional Information 2: ea6f5fe8924aaa756324d57f87834160 Additional Information 3: fd00 Additional Information 4: ea6f5fe8924aaa756324d57f87834160

Read our privacy statement:

 http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409


Change History

comment:1 Changed 10 years ago by Artem

Forgot to state the python version. It is freshly installed Python 2.6.1

Also when I close that error window, more details are available in the command line (including the stack trace). Here it is -  http://paste.turbogears.org/paste/36412

comment:2 Changed 10 years ago by Artem

Tried the same with Python 2.5.4. Same (or very similar) crash -  http://paste.turbogears.org/paste/36415 So its not 2.6 specific.

comment:3 Changed 10 years ago by Artem

  • Owner set to faide
  • Component changed from TurboGears to Installation
  • Severity changed from normal to blocker

comment:4 Changed 10 years ago by mramm

  • Milestone changed from 2.0b6 to 2.0rc1

Thanks for the report.

For now you can skip the virtualenv and install directly into your python site-packages.

Also, it would be great if you could report this on the virtualenv bug tracker:

 https://bugs.launchpad.net/virtualenv/

and/or bring it up on the virtualenv mailing list:

 http://groups.google.com/group/python-virtualenv/

comment:5 Changed 10 years ago by faide

I use python 2.5 on Vista ultimate without issue. What is the version of virtualenv you are using?

comment:6 Changed 10 years ago by faide

ie: I use python 2.5 and TG2 and even used pylunch to create my paster service and did all the tests on Vista ultimate.

comment:7 Changed 10 years ago by Artem

@mramm

For now you can skip the virtualenv and install directly into your python site-packages.

Oh, I didn't realize this. Will try.

Also, it would be great if you could report this on the virtualenv bug tracker:

I afraid I know too little about virtualenv to do it

@faide

What is the version of virtualenv you are using?

I don't know - I use the version is installed by following TG2 install docs on a clean system. It is not likely to be the concrete version problem. because couple of months earlier I had absolutely same problem with older version (TG2 beta2 I think)

comment:8 Changed 10 years ago by faide

please run:

virtualenv --version

and give us the version so that I can try to reproduce your problem on my machine...

Mine is 0.9.2.

comment:9 Changed 10 years ago by Artem

Mine is 1.3.2

comment:10 Changed 10 years ago by faide

I upgraded to 1.3.2 and it works fine. Do you have any antivirus or anything of that sort running on the machine at the time you try virtualenv?

comment:11 Changed 10 years ago by faide

your problem seems to be related with an error in _hashlib.pyd what python installer did you use? The vanilla python from python.org?

comment:12 Changed 10 years ago by Artem

I am using Symantec antivirus (will try disabling it now) I am using the latest python exactly from python.org downloads

comment:13 Changed 10 years ago by Artem

I disabled all the Symantec processes - it didn't help. Also I tried running virtualenv with the "-v" switch and there seems to be some more info -  http://paste.turbogears.org/paste/36554

comment:14 Changed 10 years ago by faide

Did you have enough rights when you installed virtualenv?

ie: did you run your easy_install command in a shell that you "run as" administrator?

comment:15 Changed 10 years ago by faide

It also seems from the traceback that you are trying to run virtualenv on an existing directory. What happens if you do this on a non-existing dir? Do you have the same craches?

comment:16 Changed 10 years ago by Artem

I don't think it matters if I run console as admin, because I am always working as a local admin :/

Anyway, I tried everything from scratch again and this time I was running console as administrator.

  1. Installed Python 2.6.1
  2. Installed setup tools (as described in  http://www.turbogears.org/2.0/docs/main/DownloadInstall.html )
  3. After that I started console as administrator and everything else can be seen at  http://paste.turbogears.org/paste/36560

Basically same crash. It looks like Python 2.6.1 doesn't have the 2.5 syntax error, but anyway crashes at the same place.

comment:17 Changed 10 years ago by Artem

And by the way, installing without virtualenv (as Mark Ramm advised) also doesn't work. No crash, installation just fails with the setup script error at the Genshi step. I shouldn't probably report it as a bug, since it was anyway a workaround, not the officially supported way.

comment:18 Changed 10 years ago by mramm

Ahh, there's no precompiled Genshi egg for 2.6 on windows in the current index. This will be fixed in the next release.

comment:19 Changed 10 years ago by Artem

I reported this bug to virtualenv tracker too -  https://bugs.launchpad.net/virtualenv/+bug/333182

comment:20 Changed 10 years ago by vinsci

On Windows XP, Python 2.5.2 installed in C:\Python25:

C:\Python25\tg2>virtualenv --no-site-packages tg2env
New python executable in tg2env\Scripts\python.exe
ERROR: The executable tg2env\Scripts\python.exe is not functioning
ERROR: It thinks sys.prefix is 'c:
python25
tg2' (should be 'c:
python25
tg2
tg2env')
ERROR: virtualenv is not compatible with this system or executable

comment:21 Changed 10 years ago by mramm

  • Priority changed from highest to normal

comment:22 Changed 10 years ago by mramm

  • Status changed from new to closed
  • Resolution set to invalid

This probably isn't a tg bug and since it's reported and will hopefully be fixed upstream, I'm going to close it here. If there's something the TG community can do to help, let us know and we'll try to make that happen.

comment:23 Changed 10 years ago by Artem

Even though it is not a TG2 own bug, it is still a problem. Could we have a workaround by making sure there are unzippable binaries (unzippable virtualenv) generated for beta releases (and for final one certainly)?

Note: See TracTickets for help on using tickets.