Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2234 (closed defect: invalid)

Opened 10 years ago

Last modified 10 years ago

controllers/root.py SecureController import in non-secure quickstart

Reported by: akean Owned by:
Priority: high Milestone: 2.0rc1
Component: TurboGears Version: 2.0b6
Severity: critical Keywords:
Cc:

Description

Right now with a fresh install, if I do a paster quickstart for a project with no authenication/authorization, there is an erroneous line in the default controllers/root.py file with instantiation of SecureController?

secc=SecureController?()

This line should be absent if no authorization is elected in a quickstarted project. As expected, the corresponding controllers/secure.py is empty.

Change History

comment:1 Changed 10 years ago by afowler

  • Priority changed from normal to high
  • Version changed from 2.0b5 to 2.0b6
  • Severity changed from normal to critical

This issue causes a "NameError: name 'SecureController' is not defined" error and traceback when the user runs "paster serve" on any newly quickstart'ed project that does not use Auth.

Raising the severity/priority of the issue, since a brand new qucikstarted project should be able to show the "hello world" screen with out an error.

comment:2 Changed 10 years ago by Gustavo

  • Status changed from new to closed
  • Resolution set to invalid

This problem is not present in b6, as you point out -- at least not in the latest trunk. It should had been in b5, but it was fixed.

As a workaround, you can just remove that line ( secc=SecureController()).

comment:3 follow-up: ↓ 4 Changed 10 years ago by afowler

I can confirm that it has been fixed in trunk.

It is, however, certainly present in b6. (Or whatever i get by runing easy_install -i http://www.turbogears.org/2.0/downloads/current/index tg.devtools right now)

comment:4 in reply to: ↑ 3 Changed 10 years ago by jorge.vargas

Replying to afowler:

I can confirm that it has been fixed in trunk.

It is, however, certainly present in b6. (Or whatever i get by runing easy_install -i http://www.turbogears.org/2.0/downloads/current/index tg.devtools right now)

that's b5 :) b6 will be out hopefully in the next flew days.

Note: See TracTickets for help on using tickets.