Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2271 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

[PATCH] import of email.parser is incompatible with python 2.4 and earlier

Reported by: PeterRussell Owned by:
Priority: high Milestone: 1.0.x bugfix
Component: TurboGears Version: 1.0 HEAD
Severity: normal Keywords: patch
Cc:

Description

The module turbogears.command.info tries to import email.parser.Parser, but prior to 2.5 this was named email.Parser.Parser. The old name works compatibly.

Attachments

2.4_email_compat.patch Download (380 bytes) - added by PeterRussell 10 years ago.
Patch to fix bug by importing older name of email parser

Change History

Changed 10 years ago by PeterRussell

Patch to fix bug by importing older name of email parser

comment:1 Changed 10 years ago by chrisz

This is a duplicate of #2317, fixed in r6574.

comment:2 Changed 10 years ago by chrisz

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.