Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2286 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

SyntaxError in catwalk/tg2/_controller.py (missing closing parenthesis)

Reported by: brainsik Owned by:
Priority: normal Milestone: 2.0final
Component: TurboGears Version: 2.0b7
Severity: normal Keywords: develop catwalk
Cc:

Description

To reproduce:

  1. Create a fresh virtualenv for 2.0b7
    1. virtualenv tg2b7
    2. . tg2b7/bin/activate
    3. easy_install -i http://www.turbogears.org/2.0/downloads/current/index tg.devtools
  2. Create a new quickstart project
    • paster quickstart (yes to auth)
  3. cd into the project and run python setup.py develop

You'll get a SyntaxError in the Catwalk egg:

Searching for Catwalk
Reading http://pypi.python.org/simple/Catwalk/
Reading http://code.google.com/p/tgtools/wiki/Catwalk
Best match: Catwalk 2.0.2
Downloading http://pypi.python.org/packages/2.5/C/Catwalk/Catwalk-2.0.2-py2.5.egg#md5=d8869ec105e0890e5e47bed5d24f7ad2
Processing Catwalk-2.0.2-py2.5.egg
creating /Volumes/Users/brainsik/src/venv/tg2b7/lib/python2.5/site-packages/Catwalk-2.0.2-py2.5.egg
Extracting Catwalk-2.0.2-py2.5.egg to /Volumes/Users/brainsik/src/venv/tg2b7/lib/python2.5/site-packages
  File "/Volumes/Users/brainsik/src/venv/tg2b7/lib/python2.5/site-packages/Catwalk-2.0.2-py2.5.egg/catwalk/tg2/_controller.py", line 162
    super(Catwalk, self).__init__(session, *args, **kwargs)
        ^
SyntaxError: invalid syntax

Adding Catwalk 2.0.2 to easy-install.pth file

Looks like this is because the line 161 (the one above the error) is missing a closing parenthesis:

    161         self.model = self.catwalkModelType(sessions
    162         super(Catwalk, self).__init__(session, *args, **kwargs)

Change History

comment:1 Changed 10 years ago by brainsik

  • Keywords develop catwalk added

Talked to percious on irc.freenode.net#turbogears and he supplied me with a working version:

[4:43pm] percious: try this: easy_install
  http://pypi.python.org/packages/source/C/Catwalk/Catwalk-2.0.2.tar.gz#md5=b455b94e6cc7fd204e7184ea60189e96
[4:43pm] percious: (you might have to first zap out your catwalk directory in your site-packages folder)
[4:44pm] percious: i will make a fresh egg for Mark to push up in the mean time
[4:47pm] percious: i guess our current index has a bug in it...
[4:47pm] percious: i have fixed it, so when rc1 is officially released, it will be fixed

comment:2 Changed 10 years ago by percious

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.