Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2290 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

tg2rc1 does not seem to function

Reported by: martinmeba Owned by:
Priority: normal Milestone:
Component: TurboGears Version: 2.0rc1
Severity: major Keywords:
Cc:

Description

I had tg2b6 installed and working on my system - linux, ubuntu 8.10. It worked just fine. I saw that rc was available so I tried to upgrade. As per the wiki, I entered the virtualenv and did: easy_install -U -i  http://www.turbogears.org/2.0/downloads/current/index tg.devtools

This failed. I did not record the error. This hosed the current install, so I blew-away the virtual environment and decided to make a new one. I issued the command: easy_install -i  http://www.turbogears.org/2.0/downloads/current/index tg.devtools

when in the virtual environment directory, issuing paster --help works. If I leave that directory, it fails with an error, which is the same error I get if I launch any previously working applications: (tg2env)martin@martin-laptop:~/Python/tg2/tg2env/Helloworld$ paster serve --reload ~/Python/tg2/Helloworld/development.ini Traceback (most recent call last):

File "/home/martin/Python/tg2/tg2env/bin/paster", line 8, in <module>

load_entry_point('PasteScript==1.7.3', 'console_scripts', 'paster')()

File "/home/martin/Python/tg2/tg2env/lib/python2.5/site-packages/PasteScript-1.7.3-py2.5.egg/paste/script/command.py", line 73, in run

commands = get_commands()

File "/home/martin/Python/tg2/tg2env/lib/python2.5/site-packages/PasteScript-1.7.3-py2.5.egg/paste/script/command.py", line 115, in get_commands

plugins = pluginlib.resolve_plugins(plugins)

File "/home/martin/Python/tg2/tg2env/lib/python2.5/site-packages/PasteScript-1.7.3-py2.5.egg/paste/script/pluginlib.py", line 81, in resolve_plugins

pkg_resources.require(plugin)

File "build/bdist.linux-i686/egg/pkg_resources.py", line 626, in require File "build/bdist.linux-i686/egg/pkg_resources.py", line 524, in resolve

pkg_resources.DistributionNotFound?: zope.sqlalchemy: Not Found for: Helloworld (did you run python setup.py develop?)

Regards, martin

Change History

comment:1 Changed 10 years ago by martinmeba

  • Status changed from new to closed
  • Resolution set to fixed

Please disregard. I didn't realize that I needed to rerun python setup.py develop. That fixed my problem.

Thanks. martin.

Note: See TracTickets for help on using tickets.