Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2305 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

WebError is not Unicode safe

Reported by: digulla Owned by:
Priority: normal Milestone:
Component: TurboGears Version: 2.0rc1
Severity: major Keywords:
Cc:

Description

If the stacktrace contains umlauts (non-ascii characters), then the code in WebError? 0.10.1 fails. The underlying issue is that WebError? uses cgi.escape() to escape special HTML characters but this method doesn't escape unicode characters and this leads to problems eventually.

My fix was to copy the code for "_encode_entity" from elementtree-1.2.7_20070827_preview-py2.6.egg into WebError?-0.10.1-py2.6.egg/weberror/evalexception.py and replace all calls to cgi.escape() with the new function.

Change History

comment:1 Changed 10 years ago by chrisz

Waht to you mean with "fails"? Do you get a server error? Then this is probably the same as #2238.

comment:2 Changed 10 years ago by digulla

  • Status changed from new to closed
  • Resolution set to duplicate

You're right, this is a duplicate of #2238. Closing.

Note: See TracTickets for help on using tickets.