Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2309 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

ToscaWidgets / JSLink Thread Safety Issue

Reported by: pedersen Owned by: percious
Priority: normal Milestone: 2.1rc1
Component: TurboGears Version: 2.0rc1
Severity: normal Keywords:
Cc:

Description

I've come across a truly unusual issue. I'm still working on finding the root cause, but I finally have enough to report the issue. I'm not sure if this is a TurboGears issue, or if it is a ToscaWidgets? issue. I'm reporting the bug in both projects.

The configuration in use when this problem occurs: TurboGears 2.0rc1 ToscaWidgets?-0.9.5dev_20081026

Running behind Apache (2.2.9-7ubuntu3) w/mod_wsgi (2.3-1), running on Ubuntu 8.10.

The problem itself is intermittent, and seems to occur about once in every four tries. It seems to be most easily reproduced with Opera.

I have packaged MochiKit? as a widget for use with my app. I wanted MochiKit? 1.4, and 1.3 was the latest included. To do so, I used the following code:

from tw.api import JSLink

mochikit = JSLink(filename="static/MochiKit.js", modname="cardlist.widgets.jslibs")

I then inserted a reference to mochikit into my base controller, using this line:

tmpl_context.mochikit = mochikit

Finally, I made sure to include the mochikit output in my master.html, so it would be accessible everywhere, using this line:

${tmpl_context.mochikit()}

The problem, when it occurred, would be visible when someone clicked the login link (going to /login ). The came_from would, sometimes, be set to "/toscawidgets/resources". When I remove the "modname" parameter from the JSLink above, the problem never occurs.

My entire codebase may be viewed by visiting  http://svn.icelus.tzo.com/

I am attempting to dig deeper into this, but felt that the bug might be able to benefit from more eyes. As such, I'm submitting finally, and hoping you can help.

Thank you!

Change History

comment:1 Changed 10 years ago by Chris Arndt

  • Owner changed from Chris Arndt to percious
  • Component changed from Widgets to TurboGears

This should be handled by someone knowledgeable about tw in tg2. Ticket got assigned to me by default, but I'm not involved with tg2. Please assign to correct developer

comment:2 Changed 10 years ago by jorge.vargas

  • Milestone set to 2.1

comment:3 Changed 9 years ago by percious

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from 2.1 to 2.1rc1
Note: See TracTickets for help on using tickets.