Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2334 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

tw.forms 0.9.6 updates breaks the forms

Reported by: shon Owned by: percious
Priority: normal Milestone: 2.1rc1
Component: TurboGears Version: 2.0b7
Severity: critical Keywords:
Cc:

Description

Please note: This is also reported on ToscaWidgets? however based on first comment I received it might be some work on TG2 tw.forms integration.

Here is the issue:

I have updated tw.forms from 0.9.3 to 0.9.6 and suprise all <div> tags generated by tw.forms are thrown back escaped like &lt;div&gt; . I did not actually realized that this is due to update for a couple of hours. Reverting back to old version solved problem for me. I use tw.forms on TG2 platform. Below is sample code to reproduce

class TicketForm(ListForm, twd.HidingTableForm):

    submit_text = "Create Ticket"
    show_errors = False

    class fields(WidgetsList):
        problemtext = Label(text='What describes your request best')

tw.forms defect link ->  http://toscawidgets.org/trac/

Discussion:  http://groups.google.co.in/group/toscawidgets-discuss/browse_thread/thread/40a7fec516af7978tw.forms/ticket/29

Change History

comment:1 Changed 10 years ago by Chris Arndt

  • Owner changed from Chris Arndt to percious
  • Component changed from Widgets to TurboGears

This should be handled by someone knowledgable about tw integration in tg2. Ticket got assigned to me by default, but I'm not involved with tg2. Please assign to correct devloper

comment:2 Changed 10 years ago by jorge.vargas

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to 2.1

0.9.7 was released to this this problem.

comment:3 Changed 9 years ago by percious

  • Milestone changed from 2.1 to 2.1rc1
Note: See TracTickets for help on using tickets.