Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2350 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

TG2 Install fails to install nose

Reported by: moore Owned by:
Priority: high Milestone: 2.0
Component: TurboGears Version: 2.0
Severity: normal Keywords:
Cc:

Description

I just tried to install TurboGears for the very first time using the instructions for version 2.0 on the site. Everything went well but when checking the installation with:

paster --help

there was no TurboGears2 block and there were two error messages halfway down the output:

Cannot load command tginfo: nose>=0.10.4 Cannot load command quickstart: nose>=0.10.4

Googling the issue I saw someone with a very similar issue (but with a different dependency error) and tried the suggested fix which was rerunning the easy_install. This had no effect. I then deleted the virtualenv directory and started from scratch, again with no effect.

I did manage to solve the issue with the command:

easy_install nose

but I am guessing that there is a dependency missing in your configuration which needs to be fixed? However I am completely new to TurboGears so my apologies if it is something I missed in the docs.

I am running on Mac OS X 10.5.8 with the standard python 2.5.1.

Change History

comment:1 Changed 8 years ago by percious

  • Status changed from new to closed
  • Resolution set to wontfix

You need to install tg.devtools as well. Turbogears2 by itself does not have a nose dependency as the package is stripped down for production usage, a place where you will not likely do your development/testing.

Note: See TracTickets for help on using tickets.