Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #239 (closed defect: fixed)

Opened 14 years ago

Last modified 12 years ago

rev 334 broke widgets/base.py on windows (havent tested in other platform)

Reported by: jorge.vargas@… Owned by: anonymous
Priority: normal Milestone: 0.9
Component: Toolbox Version:
Severity: major Keywords:
Cc:

Description

Long story short I started trying to install tg 0.9 on a clean machine. End up with many problems listed here  http://groups.google.com/group/turbogears/browse_thread/thread/2d6c1474c8618953/c18a242831dae562#c18a242831dae562 one thing let to the other and I found a bug. And I narrow it down to this. The changes made to base.py on widgets on rev 334 made me get this output from "tg-admin toolkit"

Traceback (most recent call last):

File "d:\python24\lib\site-packages\CherryPy?-2.1.0-py2.4.egg\cherrypy\_cphttptools.py", line 271, in run

main()

File "d:\python24\lib\site-packages\CherryPy?-2.1.0-py2.4.egg\cherrypy\_cphttptools.py", line 502, in main

body = page_handler(*args, cherrypy.request.paramMap)

File "D:\programas\python\TurboGears\turbogears\controllers.py", line 196, in newfunc

html, *args, kw)

File "D:\programas\python\TurboGears\turbogears\database.py", line 174, in run_with_transaction

retval = func(*args, kw)

File "D:\programas\python\TurboGears\turbogears\controllers.py", line 225, in _execute_func

return _process_output(tg_format, output, html)

File "D:\programas\python\TurboGears\turbogears\controllers.py", line 60, in _process_output

output = view.render(output, tg_format, template=template)

File "D:\programas\python\TurboGears\turbogears\view.py", line 107, in render

return t.serialize(encoding=defaultencoding, output=format, fragment=fragment)

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\init.py", line 232, in serialize

return serializer.serialize(self, encoding, fragment)

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\serialization.py", line 51, in serialize

text = list(self.generate(stream, encoding, fragment))

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\serialization.py", line 319, in generate

for ev, item in self.apply_filters(stream):

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\serialization.py", line 77, in balancing_filter

for ev, item in stream:

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\pull.py", line 203, in _coalesce

for ev, item in stream:

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\filter.py", line 21, in transform_filter

for ev, item in apply_matches(stream, template, templates, apply_func):

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\filter.py", line 31, in apply_matches

item = stream.expand()

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\pull.py", line 95, in expand

for ev, item in self._iter:

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\pull.py", line 164, in _track

for p in stream:

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\pull.py", line 203, in _coalesce

for ev, item in stream:

File "D:\programas\python\TurboGears\turbogears\toolbox\widgets.py", line 144, in _pull File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\filter.py", line 21, in transform_filter

for ev, item in apply_matches(stream, template, templates, apply_func):

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\filter.py", line 25, in apply_matches

for ev, item in stream:

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\pull.py", line 164, in _track

for p in stream:

File "d:\python24\lib\site-packages\kid-0.8-py2.4.egg\kid\pull.py", line 203, in _coalesce

for ev, item in stream:

File "<string>", line 33, in _pull

AttributeError?: 'SelectField?' object has no attribute 'options'

Change History

comment:1 Changed 14 years ago by Luca <luca@…>

Have you tested a more recent revision? It works just fine on Linux (Debian sid).

If the problem is still there, can you paste the traceback between 3 brakets, so it's formatted as code? (See WikiFormatting)

comment:2 Changed 14 years ago by Luca <luca@…>

  • Component changed from Widgets to Toolbox

comment:3 Changed 14 years ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

There's been so much done on widgets since this point, I'm closing this ticket. If there are further future problems, we can open a new one.

Note: See TracTickets for help on using tickets.