Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2420 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

paster quickstart -m does not produce the proper mako templates

Reported by: seedifferently Owned by: percious
Priority: normal Milestone: 2.1b1
Component: TurboGears Version: trunk
Severity: normal Keywords:
Cc:

Description

In TG2.1 alpha 3, using paster quickstart with the Mako option does not produce Mako templates. Trying to run the app after quickstart throws a server error.

Change History

comment:1 Changed 10 years ago by jorge.vargas

I am not able to reproduce this. Could you give us a set of steps?

comment:2 Changed 10 years ago by jorge.vargas

  • Milestone changed from __unclassified__ to 2.1b1

comment:3 Changed 10 years ago by seedifferently

Jorge,

  1. Create a new virtualenv (python 2.6)
  2. Run the TG2.1 setup: easy_install -i  http://www.turbogears.org/2.1/downloads/current/index tg.devtools
  3. Do a quickstart and say yes to mako and to authorization.

It's strange, because the quickstart copies the *.mak template files into tg21env/HelloWorld/HelloWorld/templates and the Genshi template files into tg21env/HelloWorld/helloworld/templates (the proper dir).

Judging from the different dir case names, perhaps this is Linux specific (I'm on Ubuntu Karmic).

Seth

comment:4 Changed 9 years ago by percious

Okay, this is a case-sensitivity issue. I'll have it fixed pretty quickly.

comment:5 Changed 9 years ago by percious

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.