Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2448 (closed defect: migrated)

Opened 9 years ago

Last modified 8 years ago

Genshi xi:include Caching Issue

Reported by: rpetrello Owned by:
Priority: normal Milestone: 2.1
Component: TurboGears Version: 2.1
Severity: normal Keywords:
Cc:

Description

We're experiencing a caching issue with genshi when we include two different files in two different directories that happen to have the same name. I'm not sure if this is actually a Genshi defect, or if it belongs in TG, but I figured it was enough of an issue to bring up here. Example:

templates/examplea/index.html includes templates/examplea/include.html templates/exampleb/index.html includes templates/exampleb/include.html

Sometimes when visiting the controller hooked to the exampleb template, the examplea include is used (and vice-versa).

To illustrate, I've attached a quickstart project that illustrates this behavior. To replicate:

  • Run the quickstart project and visit localhost:8080.
  • At the bottom of the root page, click the link that takes you to the second page.
  • On the second page, click the link that takes you back to the first page.

Our Genshi version: 0.5.1 We're able to reproduce this in TG2.1a3+ (including the most recent 2.1b1).

Attachments

GenshiBug.zip Download (131.7 KB) - added by rpetrello 9 years ago.

Change History

Changed 9 years ago by rpetrello

comment:1 Changed 9 years ago by rpetrello

Worth mentioning - this is very possibly a Genshi bug. In fact, this ticket in Genshi's tracker describes our issue perfectly:  http://genshi.edgewall.org/ticket/240

comment:2 Changed 9 years ago by percious

  • Priority changed from normal to high
  • Severity changed from normal to major
  • Milestone changed from __unclassified__ to 2.1b2

comment:3 Changed 9 years ago by mramm

  • Priority changed from high to normal
  • Severity changed from major to normal

If we can't fix this, we need to lean on the genshi folks, but I'm going to mark down the priority since it's not something we can change in our code, and I don't think it should be a blocker for a 2.1 release.

comment:4 Changed 9 years ago by percious

  • Version changed from 2.1a3 to 2.1
  • Milestone changed from 2.1rc1 to 2.1

comment:5 Changed 8 years ago by pedersen

  • Status changed from new to closed
  • Resolution set to migrated
Note: See TracTickets for help on using tickets.