Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2455 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Admin list view fails with more than 8 records

Reported by: chrisz Owned by: percious
Priority: normal Milestone: 2.1
Component: tg-admin (non-toolbox) Version: 2.1
Severity: normal Keywords: admin paginate
Cc:

Description

The following was reported on the  mailing list and I can confirm it's still happening in the TG 2.1 trunk.

Create more than 8 records in admin view of anything and it will try to paginate and it will fail with:

GenerationException: url_for could not generate URL. Called with args: () {'page': 2}

Change History

comment:1 Changed 9 years ago by mramm

  • Milestone changed from 2.1 to 2.1b2

comment:2 Changed 9 years ago by percious

  • Status changed from new to assigned
  • Owner set to percious

comment:3 Changed 9 years ago by percious

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:4 Changed 9 years ago by mu_mind

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm still seeing this bug on the 2.1b2 release:

GenerationException: url_for could not generate URL. Called with args: () {'link': './FOO', 'page': 2} (when trying to visit "/admin/FOO")

comment:5 Changed 9 years ago by mramm

  • Milestone changed from 2.1b2 to 2.1rc1

comment:6 Changed 9 years ago by pedersen

  • Component changed from TurboGears to tg-admin (non-toolbox)

Switching component to tg-admin, as this is about tgext.admin, instead of TG core itself.

comment:7 Changed 9 years ago by mramm

  • Priority changed from high to normal
  • Severity changed from major to normal

This should also not block a 2.1 release

comment:8 Changed 9 years ago by percious

  • Version changed from trunk to 2.1
  • Milestone changed from 2.1rc1 to 2.1

comment:9 Changed 9 years ago by mu_mind

This particular error seems to be fixed now. There's a more minor bug that the pagination links are messed up, going to e.g. "/admin/FOO/FOO?page=2" instead of "/admin/FOO?page=2". Shall I mark this fixed and open a separate ticket for the remaining problem?

comment:10 Changed 9 years ago by chrisz

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks mu_mind, I've already created #2538 for that.

Note: See TracTickets for help on using tickets.