Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #2522 (closed defect: migrated)

Opened 7 years ago

Last modified 7 years ago

tg.decorators.https improperly handles 405

Reported by: seedifferently Owned by:
Priority: normal Milestone: 2.1
Component: TurboGears Version: 2.1
Severity: normal Keywords:
Cc:

Description

When TG's @https decorator throws a 405 error, I believe the appropriate header response should be "Allow: GET" instead of "allowed: GET" as it is currently.

Please review the attached patch, as well as RFC2616 (page 105, section 14.7).

Thanks, Seth

Attachments

decorators.py.patch Download (491 bytes) - added by seedifferently 7 years ago.
Patched 405 error header

Change History

Changed 7 years ago by seedifferently

Patched 405 error header

comment:1 Changed 7 years ago by percious

  • Version changed from 2.1rc1 to 2.1
  • Milestone changed from __unclassified__ to 2.1rc1

comment:2 Changed 7 years ago by percious

  • Milestone changed from 2.1rc1 to 2.1

comment:3 Changed 7 years ago by pedersen

  • Status changed from new to closed
  • Resolution set to migrated
Note: See TracTickets for help on using tickets.