Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #301 (closed enhancement: fixed)

Opened 13 years ago

Last modified 12 years ago

[PATCH] Add option to set the SubmitButton text (value) in insert() method to TableForm

Reported by: Luca <luca@…> Owned by: anonymous
Priority: normal Milestone: 0.9
Component: TG Widgets Version:
Severity: normal Keywords: tableform submit submittext view insert
Cc:

Description

For easy TableForm? reuse, with this simple patch you can change the submittext in the view:

${form.insert(submittext="Save")

Attachments

turbogears-r411-form-insert-submittext.patch Download (1.6 KB) - added by Luca <luca@…> 13 years ago.

Change History

Changed 13 years ago by Luca <luca@…>

comment:1 Changed 13 years ago by kevin

  • Status changed from new to closed
  • Resolution set to duplicate

With the patch submitted for #306, I believe you can now do this without any changes to forms.py.

comment:2 Changed 13 years ago by kevin

that was actually #304.

comment:3 Changed 13 years ago by Luca <luca@…>

Is there any place where I can read how to do this with the patch in #304?

comment:4 Changed 13 years ago by michele

Luca, I will look at this within two hours because I'm working on somenthing related, Jorge Godoy (IIRC) pointed out that he would like to use the browser automatic translation for submit buttons labels.

comment:5 Changed 13 years ago by michele

  • Status changed from closed to reopened
  • Resolution duplicate deleted

This patch should be committed.

This is indeed needed to fix submittext that's actually broken.

The other one, #302, it's not needed because the issue is fixed (for the moment but there could be a better solution I think) by my patch in #304.

If you don't specify a submittext the browser puts there the right text for a submit button.

comment:6 Changed 13 years ago by kevin

  • Status changed from reopened to closed
  • Resolution set to fixed

committed at [453]. Thanks!

Note: See TracTickets for help on using tickets.