Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #331 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

[PATCH] Comment on docs/toolbox/catwalk.html

Reported by: j-turbogears@… Owned by: anonymous
Priority: normal Milestone:
Component: Documentation Version:
Severity: normal Keywords:
Cc:

Description

I don't understand. Maybe I'm too much of a python/tg noob to figure it out... but your example doesn't work as written.

I inserted it into my sample project's controllers.py file as instructed in the example on the page.

Instead of getting to browse to /catwalk, I am unable to launch the CherryPy? server because it now errors out with "ImportError?: No module named catwalk".

Anyone want to update the docs with a reason why my turbogears doesn't include CatWalk?? -- I.e. ... I didn't explicitly include it in some build parameter (which no one mentioned) or other similar option? ... It's not included in the default package (and where one can download it)? ... It's misspelled in the sample on the page? ... Anything??

Thanks!

Attachments

catwalk-import-doc.diff Download (555 bytes) - added by bbockelm@… 13 years ago.
Change to docs to reflect different import line for catwalk.

Change History

comment:1 Changed 13 years ago by sc@…

It could be because of this (see this thread on mounting Catwalk)  http://groups.google.com/group/turbogears/browse_thread/thread/bad11318a62b2504/

Otherwise, you can always launch Catwalk by entering

tg-admin toolbox

at the root directory of your project.

comment:2 Changed 13 years ago by bbockelm@…

  • Summary changed from Comment on docs/toolbox/catwalk.html to [PATCH] Comment on docs/toolbox/catwalk.html

First of all, what version of the SVN are you using? At some point, catwalk was moved from turbogears.catwalk to the more logical turbogears.toolbox.catwalk. This may be your problem. You'll need the following:

from turbogears.toolbox.catwalk import CatWalk

instead of

from turbogears.catwalk import CatWalk

Make sure that the directory turbogears/toolbox/catwalk exists. If not, you're probably using an older version of turbogears.

Remember - there's a lot of changes between .8 and .9; as .9 isn't even out yet, there's still going to be a lot of upheaval.

Nevertheless, I'll attach a small one-line patch that should fix the docs.

Changed 13 years ago by bbockelm@…

Change to docs to reflect different import line for catwalk.

comment:3 Changed 13 years ago by SuperJared <jared.kuolt@…>

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.