Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #390 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

VALUE="<built-in method title of str" in widget if name is "title"

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 0.9
Component: TG Widgets Version: 0.9a6
Severity: normal Keywords:
Cc:

Description

When using the TextField? widget if the name parameter is "title" it creates the following default value:

<INPUT TYPE="text" NAME="title" VALUE="<built-in method title of str object at 0x009BA038>">

Change History

comment:1 Changed 13 years ago by anonymous

  • Component changed from CherryPy to Widgets

comment:2 Changed 13 years ago by anonymous

  • Milestone set to 0.9

comment:3 Changed 13 years ago by Mike Kent (mrmakent@…

This is the same bug as reported in # 272. See  http://groups.google.com/group/turbogears/browse_frm/thread/60f8c54aaf005dfe/14d3929c1d0f5114#14d3929c1d0f5114 for the cause of this bug. The intent of the bugged code is not clear to me, so no patch yet.

comment:4 Changed 13 years ago by michele

Dunno why but this seems to work using the newbase.py and newforms.py

>>> test = w.TextField(name="title")
>>> test.render()
'<INPUT CLASS="textfield" TYPE="text" ID="form_title" NAME="title">'

comment:5 Changed 13 years ago by michele

  • Status changed from new to closed
  • Resolution set to fixed

Related to #272, that's fixed now.

Note: See TracTickets for help on using tickets.