Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #393 (closed enhancement: fixed)

Opened 14 years ago

Last modified 12 years ago

Comment on download/windows.html

Reported by: msluyter@… Owned by: anonymous
Priority: normal Milestone:
Component: Documentation Version:
Severity: normal Keywords:
Cc:

Description

Hi, Python has been my favorite general purpose language for a while now, but I'm fairly new to web development, so I thought I'd check out TurboGears. I encountered one stumbling block that you might want to incorporate into your installation instructions:

If you're going through a proxy, you need to set the http_proxy environment variable in order for ez_setup.py to work:

export http_proxy=" http://your.proxy.com:8000"

(I did that within Cygwin on Windows.) It took looking at ez_setup.py and then the documentation for urllib2 to figure out, which wasn't all that much of an ordeal, but it might be nice to save others time by adding a step to your install page.

Thanks! Mike Sluyter

Change History

comment:1 Changed 13 years ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

I've added a note to the installation troubleshooting page about setting the http_proxy environment variable.

Note: See TracTickets for help on using tickets.