Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #408 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

auto reload causes server crashe whe RelatedJoin is used in model

Reported by: bergraj@… Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version:
Severity: major Keywords:
Cc:

Description

When you use a RelatedJoin? in your model the auto reload causes the server to crash frequently (it only crashes after a http request has been made and auto reload has been triggered).

Steps to reproduce:

  1. Create a minimal project that uses RelatedJoin? in the model and imports model in controller.py
  1. Request a page on  http://localhost:8080
  1. trigger an auto reload (e. g. by 'touch controllers.py')

Now the auto reload fails for no obvious reason! If it doesn't work the first time repeat steps 2. and 3. some more time.

On my box the server crashes most of the time after the first request-reload cycle, making development somewhat hard (this is why i chose for Severity major).

I attached the server output (all i got from starting it to the mysterious shutdown), the controllers.py and the model.py (the ones i used in my minimal example).

Attachments

server_output Download (1.6 KB) - added by anonymous 13 years ago.
controllers.py Download (1.0 KB) - added by anonymous 13 years ago.
model.py Download (407 bytes) - added by anonymous 13 years ago.

Change History

Changed 13 years ago by anonymous

Changed 13 years ago by anonymous

Changed 13 years ago by anonymous

comment:1 Changed 13 years ago by bergraj@…

Well i forgot to mention..

TruboGears? svn r518 with Python 2.4.2 on Gentoo GNU/Linux.

comment:2 Changed 13 years ago by kevin

Here's another note:

Yup got it too. xp-pro sp2, r518, sqlite3. DrWatson log says something
about a violation by Py_CheckRecursiveCall.

comment:3 Changed 13 years ago by anonymous

  • Status changed from new to closed
  • Resolution set to fixed

Fixed! A big thanks goes to Max Ischenko!

comment:4 Changed 13 years ago by anonymous

fixed since rv537

Note: See TracTickets for help on using tickets.