Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #421 (closed defect: wontfix)

Opened 13 years ago

Last modified 9 years ago

easy_install turbogears==dev doesn't work

Reported by: ianb@… Owned by: anonymous
Priority: normal Milestone: irrespective
Component: Installation Version:
Severity: normal Keywords:
Cc: ianb@…, mramm

Description

Sadly I cannot quite install TG 0.9 from svn with easy_install turbogears==dev. First I have to use -f http://turbogears.org/download/, which might not be necessary if the cheese shop page linked to that download page itself. Secondly, CherryPy? 2.2 isn't linked from anywhere. A link to  http://svn.cherrypy.org/trunk/#egg=CherryPy-dev will help, along with a requirement of CherryPy==dev,>2.1.1 Once I work around both those issues, it Just Works.

Change History

comment:1 Changed 13 years ago by jorge.vargas

the current state of develop does not support this, ones the preview site merges with the main site I'll have a look into it.

comment:2 Changed 13 years ago by fredlin

  • Milestone set to 1.0b1

It seems a possible enhancement for tgsetup.py

comment:3 Changed 13 years ago by jorge.vargas

the -f is fix now about having cherrypy dev, that currently points to CP3.0 which (correct me if I'm wrong) TG is not prepared to support yet.

if that's the case this should be closed with wontfix/invalid.

comment:4 Changed 13 years ago by jorge.vargas

I notice that TurboGears==dev is actually pointing you to the trunk which has the OLD start page for projects.

comment:5 Changed 13 years ago by khorn

  • Milestone changed from 1.0b1 to 1.0b3

milestone passed, moving to 1.0b3 (1.0b2 is pretty full!)

also, this was originally reported as for 0.9, can we confirm whether this is still even a problem?

comment:6 Changed 12 years ago by alberto

  • Milestone changed from 1.0b3 to 1.1

comment:7 Changed 12 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:8 Changed 12 years ago by Chris Arndt

easy_install TurboGears==dev finds, downloads and installs the TurboGears from SVN (as of r3838), but it does not install the depencies, easy_install just quits with this message:

Skipping dependencies for TurboGears2 2.0a1dev-r3838

easy_install http://svn.turbogears.org/trunk works and installs the dependencies it can find, but fails when trying to download RuleDispatch?, because it is not listed in the Cheeseshop.

So to install TG2 from SVN, you have to use this monster:

[sudo] easy_install [-UZ] [--prefix=/usr/local] \
    -f http://www.turbogears.org/download/filelist.html \
    http://svn.turbogears.org/trunk

But this will probably not give you a working TG2 installation either, because TG2 needs Pylons straight from the (mercurial) repository at the moment. See also INSTALL.txt.

comment:9 Changed 11 years ago by Chris Arndt

  • Cc mramm added

With Pylons in mercurial, this will probably neither be fixable, or will it?

Should this be closed with "wontfix"?

comment:10 Changed 10 years ago by jorge.vargas

  • Status changed from new to closed
  • Resolution set to wontfix

easy_install will probably never support this, maybe pip but that's another ticket.

comment:11 Changed 9 years ago by chrisz

  • Milestone changed from __unclassified__ to irrespective
Note: See TracTickets for help on using tickets.