Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #483 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

Toolbox should have its own configuration

Reported by: tim@… Owned by: anonymous
Priority: high Milestone: 0.9
Component: Toolbox Version:
Severity: major Keywords:
Cc:

Description (last modified by kevin) (diff)

The Toolbox is a TurboGears app. It's somewhat unique in that when it runs, it uses the configuration of the application that you're developing. The Toolbox should either read in the user's project config separately and pull the parts it needs or the Toolbox should have its own config that is loaded after the user's config to set things like the default template type, etc.

Attachments

toolboxport.patch Download (500 bytes) - added by tim@… 13 years ago.
Fixes the hardcoded browser port when launching the toolbox.

Change History

Changed 13 years ago by tim@…

Fixes the hardcoded browser port when launching the toolbox.

comment:1 Changed 13 years ago by tim@…

I thought about it some more, and I suppose that an alternate solution would be to ensure that CherryPy? always starts on port 7654 when in toolbox mode. That would allow both the application and the toolbox to run at the same time. Let me know if that's the preferred solution -- I'll write up a patch to do that tonight after work if that is the case.

comment:2 Changed 13 years ago by kevin

  • Summary changed from [PATCH] Toolbox Server/Browser Port agreement to Toolbox Server/Browser Port agreement

Good catch!

You're right, though... the idea is that the toolbox should be running on its own distinct port rather than the same port as the app.

comment:3 Changed 13 years ago by kevin

  • Priority changed from lowest to high
  • Milestone set to 0.9
  • Summary changed from Toolbox Server/Browser Port agreement to Toolbox should have its own configuration
  • Description modified (diff)
  • Severity changed from trivial to major

I'm hijacking this ticket to fix Toolbox configuration in general. The Toolbox's functionality needs to be configured according to the Toolbox's needs. The only thing (at this point) that really needs to come from user config is the DBURI.

comment:4 Changed 13 years ago by kevin

#428 is now a duplicate of this ticket.

comment:5 Changed 13 years ago by viyyer@…

I think it would make more sense if the port on which toolbox runs is modificable on run time something like tg-admin toolbox -p 10000

comment:6 Changed 13 years ago by godoy

What's the status of this "hijacked" ticket? ;-)

comment:7 Changed 13 years ago by elvelind

  • Status changed from new to closed
  • Resolution set to fixed

fixed in 1635. there is now an -p/--port option and toolbox ignores everything but the dburi part on a projects configfile.

Note: See TracTickets for help on using tickets.