Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #5 (closed defect: fixed)

Opened 13 years ago

Last modified 11 years ago

docgen needs to handle versions

Reported by: kevin Owned by: anonymous
Priority: normal Milestone: 0.8
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

docgen.py, the website generator for TurboGears, needs to be able to generate a website with multiple versions of the docs directory. This is needed so that the current trunk docs, current version docs and earlier version docs are all available.

Change History

comment:1 Changed 13 years ago by kevin

  • Component changed from CherryPy to TurboGears

comment:2 Changed 13 years ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

At the moment, I have started generating the website out of the TurboGears 0.5.1 tag. The site now brings in the local copy of the latest development docs and provides links to switch between them.

This will work for now. A better solution will be to move the site to a new project and pull the documentation sections from each version.

comment:3 Changed 13 years ago by kevin

I'm not going to open a ticket on moving the site to a separate project just yet. I want to see how the transition goes to the 0.8 version of the site and see if it really makes a difference.

Note: See TracTickets for help on using tickets.