Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #53 (closed defect: duplicate)

Opened 14 years ago

Last modified 12 years ago

Comment on docs/wiki20/page6.html

Reported by: GreenTea Owned by: anonymous
Priority: low Milestone:
Component: Documentation Version:
Severity: minor Keywords:
Cc:

Description

I had to restart the server in order to see the changes in the master.kid expressed on the web page. So, until I restarted the server, the pagelist redirected to the pagelist page. After restarting the server, the pagelist was displayed in the same page.

-Todd

Let's create our row_display function and close off our script tag:
1	function row_display(pagename) { 
2	    return LI(null, A({"href" : "${std.url('/')}" + pagename}, pagename)) 
3	} 
4	</script> 
	view plain | print | ?

Each pagename from the pages list will get passed into row_display. We create an LI element (no attributes), and an A element with an href attribute. The A element also has the pagename as its contents.

Voila! If you go to your front page and click on the page list link, you'll see the page list right there in the page.

Change History

comment:1 Changed 14 years ago by Norbert.Klamann@…

I noticed this several times and suggest a documentation change (where?).

'Changes in master.kid take effect after a restart of the server.'

comment:2 Changed 14 years ago by kevin

  • Status changed from new to closed
  • Resolution set to duplicate

dupe of #55

Note: See TracTickets for help on using tickets.