Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #564 (closed defect: fixed)

Opened 9 years ago

Last modified 7 years ago

[PATCH] tg-admin update does not work on win32

Reported by: krys@… Owned by: anonymous
Priority: high Milestone: 0.9
Component: TurboGears Version:
Severity: blocker Keywords:
Cc:

Description

tg-admin update says:

it looks like your project dir "E:\Krys\marvin" is named wrongly. Please rename it to "marvin"

The problem is this line in quickstart.py:

127  currentdir = os.getcwd().split("/")[-1]

That is pretty platform specific. My patch changes it to:

127 currentdir = os.path.basename(os.getcwd())

and adds the necessary import to os.path.

Attachments

turbogears-quickstart.py-win32.patch Download (868 bytes) - added by krys@… 9 years ago.

Change History

Changed 9 years ago by krys@…

comment:1 Changed 9 years ago by elvelind@…

  • Status changed from new to closed
  • Resolution set to fixed

thanks krys. commited in 757

Note: See TracTickets for help on using tickets.