Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #566 (closed defect: duplicate)

Opened 13 years ago

Last modified 12 years ago

[PATCH] tg-admin update fails on windows due to non-unix file separator

Reported by: nyenyec Owned by: anonymous
Priority: normal Milestone: 0.9
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

tg-admin assumes that '/' is the file separator, which makes it fail on Windows.

Example output:

c:\local\python\turbowp>tg-admin update
it looks like your project dir "c:\local\python\turbowp" is named wrongly. Pleas
e rename it to "turbowp"

c:\local\python\turbowp>

Attachments

os_sep.patch Download (783 bytes) - added by nyenyec 13 years ago.

Change History

Changed 13 years ago by nyenyec

comment:1 Changed 13 years ago by nyenyec

  • Summary changed from tg-admin update fails on windows due to non-unix file separator to [PATCH] tg-admin update fails on windows due to non-unix file separator

Attached patch that uses os.sep instead of '/'

comment:2 Changed 13 years ago by nyenyec

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #564

Note: See TracTickets for help on using tickets.