Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #579 (closed defect: wontfix)

Opened 12 years ago

Last modified 10 years ago

Catwalk is extremely slow on large tables

Reported by: bjourne@… Owned by: anonymous
Priority: high Milestone:
Component: Toolbox Version:
Severity: major Keywords:
Cc:

Description

If you have a table with over 10000 rows it becomes impossible to browse it because CatWalk becomes unbearably slow. The Javascript always times out multiple times each page view.

Change History

comment:1 Changed 12 years ago by Joost

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate: Ticket #349

comment:2 Changed 12 years ago by bjourne@…

  • Status changed from closed to reopened
  • Resolution duplicate deleted

This is a different problem than #349. #349 is a problem because CatWalk do not have paging support for viewing MultipleJoin? records. This slowness occurs when you click on the Browse tab on a table that has a huge number of records. Even though CatWalk pages the results in chunks of ten per page.

comment:3 Changed 12 years ago by bjourne@…

The slowness seem to be caused by the catwalk.page_selector function in catwalk.js. When there are 100000 rows in the table, it tries to append 10000 option-tags to the select attribute that is the element that creates "the 5 of 100000" select input box. I wonder if raising the granularity on the select-list when there are more than a few hundred pages would be a workable workaround? So that instead of listing every page from 1 to 10000, the select would go 1, 10, 20, 30, 40.. etc? I guess it could be raised to 1, 100, 200, 400 when there are one million rows and so on.

comment:4 Changed 11 years ago by kevin

  • Status changed from reopened to closed
  • Resolution set to wontfix

While I might take a patch for this, I have no intention of working on this and, to my knowledge, neither does Ronald.

CatWalk is intended for doing manipulations on small databases when you're in development. Ultimately, the goal is that CatWalk will be supplanted by a beefed up version of FastData? which *will* support large tables.

So, there's an issue here but I'm going to close this as wontfix.

comment:5 Changed 11 years ago by bjourne

There is a patch at #589. Please review.

Note: See TracTickets for help on using tickets.