Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #614 (closed defect: fixed)

Opened 12 years ago

Last modified 8 years ago

Kid serialization add new line in tables

Reported by: ronald@… Owned by: anonymous
Priority: normal Milestone: 1.x
Component: View Version:
Severity: normal Keywords: Kid, needs confirmation
Cc: ronald@…

Description

Somewhere along the toolchain, spaces are been added to kid templates. I'm not sure if it is Kid's serializer (I can't reproduce this when testing from tg-admin shell). This breaks layouts that use tables and sliced images, due to a rendering bug in MSIE. MSIE will add padding or extra space around an image if there is a new line beetween the image and the enclosing td tag. This has been reported in Kids tracker ( http://kid.lesscode.org/trac/ticket/121) but the current status is 'wontfix', they advice you to set: serializer.balanced_blocks = False I tried that with plugins/kid/turbokid/kidsupport.py but with no luck. I attached a basic kid template with to tables. MSIE should render the first table with a 2px gap beetwen the two images, and the second table without any gap (try changing the extension from .kid to .html an dropping the file on MSIE). If you quickstart a new app and replace the welcome.kid file with the one attached here and go to localhost:8080 you will see gaps in both tables. You can see trough IE's view source that spaces has been added before the enclosing td tag.

Attachments

welcome.kid Download (1.1 KB) - added by ronald@… 12 years ago.

Change History

Changed 12 years ago by ronald@…

comment:1 Changed 11 years ago by jorge.vargas

this is seems to be related to #409

comment:2 Changed 11 years ago by alberto

  • Milestone changed from 1.0 to 1.1

comment:3 Changed 11 years ago by jorge.vargas

as #409 please check if this is still present with newer kid versions.

comment:4 Changed 11 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:5 Changed 9 years ago by Chris Arndt

  • Keywords Kid, needs confirmation added; Kid views removed
  • Component changed from Kid to View

comment:6 Changed 9 years ago by jorge.vargas

  • Milestone changed from __unclassified__ to 1.x

comment:7 Changed 8 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to fixed

According to ticket #409 Kid was fixed in this regard since version 0.9.4.

Note: See TracTickets for help on using tickets.