Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #620 (closed defect: worksforme)

Opened 13 years ago

Last modified 9 years ago

html pages with \n in output

Reported by: j^ Owned by: anonymous
Priority: normal Milestone: 1.0.4
Component: Toolbox Version: 1.0.4b3
Severity: normal Keywords:
Cc: michele

Description

DataController or the wdigetbrowser of tg-admin toolbox have lots of \n in the htmloutput and make the interface next to unusable. this is with TurboGears 0.9a1

Change History

comment:1 Changed 13 years ago by anonymous

  • Component changed from CherryPy to TurboGears

comment:2 Changed 13 years ago by anonymous

Hi

I've filed this bug: http://trac.turbogears.org/turbogears/ticket/627 which has been marked as a (possible) duplicate of this bug. In my own experience, the \n was only added in the <script> sections, making imposible use of AJAX. I've tried opening mi .kid templates in windows xp notepad and assuring the files are saved as utf8 but didn't worked.

Please ask me what ever information you need to fix this very annoying bug. Thanxs

comment:3 Changed 13 years ago by anonymous

Hi

I'm having the same problem in the toolbox: If I launch the "tg-admin toolbox" command and start using the model utility (to create data in the database) the "Save" button doesn't work because the htmloutput has \n on every <script> tag.

comment:4 Changed 13 years ago by godoy

  • Cc michele added

Do you still have problems with this? What OS and version of it are you using? Do you see this in all browsers? In which browsers and which versions of them does this occur?

Michele had a problem like this with Ubuntu Dapper. I'll add him to the CC so that he can add more details and explain how he solved this problem.

comment:5 Changed 13 years ago by anton@…

  • Version set to 0.9a5

Similar problem here, on mac

  • Turbogears : New install of 0.9a5
  • Python 2.4.2 on MacOS X 10.4.6 (intel)
  • Browser : Firefox and Safari

On a freshly quickstarted project, \n are all over the generated HTML. For exemple, on the toolbox, you've got :

'\n TurboGears System Information. Lists your TurboGears packages and version information \n'

This was working with 0.9a1...

comment:6 Changed 13 years ago by jorge.vargas

  • Milestone changed from 0.9 to 1.0

comment:7 Changed 13 years ago by jorge.vargas

  • Component changed from TurboGears to Toolbox

comment:8 Changed 13 years ago by jorge.vargas

  • Milestone changed from 1.0 to 1.0b4

comment:9 Changed 12 years ago by alberto

  • Milestone changed from 1.0b4 to 1.1

comment:10 Changed 12 years ago by alberto

  • Milestone changed from 1.1 to __unclassified__

Batch moved into unclassified from 1.1 to properly track progress on the later

comment:11 Changed 11 years ago by Chris Arndt

  • Status changed from new to closed
  • Resolution set to worksforme

I cannot reproduce this anymore with TG 1.0.4b3. Closing this ticket now.

comment:12 Changed 9 years ago by chrisz

  • Version changed from 0.9a5 to 1.0.4b3

comment:13 Changed 9 years ago by chrisz

  • Milestone changed from __unclassified__ to 1.0.4
Note: See TracTickets for help on using tickets.