Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #627 (closed defect: duplicate)

Opened 13 years ago

Last modified 12 years ago

inline javascript in .kid templates generates invalid html output

Reported by: kmon Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

Hi

I've recently installed tg 0.8.9. I've been following the 20 minutes wiki tutorial and when I reached the ajax example, I've noticed that including inline javascrit in the master.kid template makes the server render invalid escape character \n in every javascript line. I've tried including a CDATA element and other things but nothing worked.

I'm attaching the complete proyect and the invalid rendered HTML output.

Thanxs

Attachments

wiki.tar.gz Download (12.1 KB) - added by anonymous 13 years ago.
the proyect.
index.html.tar.gz Download (895 bytes) - added by kmon 13 years ago.
the invalid html output

Change History

Changed 13 years ago by anonymous

the proyect.

Changed 13 years ago by kmon

the invalid html output

comment:1 Changed 13 years ago by anonymous

Ive just reinstalled tg 0.9 and I'm having the same problem. I've asked for help in the mail list and in the forum and no one seems to find the exact problem... I'm clueless

comment:2 Changed 13 years ago by MaciekL

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from CherryPy to TurboGears

Looks like a duplicate of #620

Note: See TracTickets for help on using tickets.