Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #628 (closed defect: fixed)

Opened 9 years ago

Last modified 7 years ago

[PATCH] ModelDesigner can't find correct path to model.py

Reported by: nerkles Owned by: anonymous
Priority: normal Milestone: 0.9
Component: Toolbox Version:
Severity: major Keywords: ModelDesigner
Cc:

Description

The source of this bug may actually be someplace else, but it seems that if you give a different name in the 2nd step of quickstart, then ModelDesigner? does not find where to write the model.py file. It's guessing the wrong path.

For example:

$ tg-admin quickstart

Enter project name: SomeTestProject?

Enter package name [sometestproject]: testproj

Selected and implied templates:

TurboGears#turbogears web framework

... snip etc etc...

Next create an object or two and try to write the model file. I got a JS dialog saying:

Failed to save /Users/Shared/SomeTestProject/SomeTestProject?/model.py

whereas the correct path should be:

/Users/Shared/SomeTestProject?/testproj/model.py

(this is with SVN 980, but I think this bug has been around a while)

Attachments

toolbox.designer.patch Download (634 bytes) - added by roger.demetrescu 9 years ago.

Change History

comment:1 Changed 9 years ago by nerkles

oops, meant SVN 865...

comment:2 Changed 9 years ago by roger.demetrescu

  • Summary changed from ModelDesigner can't find correct path to model.py to [PATCH] ModelDesigner can't find correct path to model.py

Changed 9 years ago by roger.demetrescu

comment:3 Changed 9 years ago by ronald@…

  • Status changed from new to closed
  • Resolution set to fixed

Patched in rev904. Thanks Nerkles for the ticket and Roger for the patch

Note: See TracTickets for help on using tickets.