Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #631 (closed defect: fixed)

Opened 13 years ago

Last modified 8 years ago

typos for preview download page

Reported by: Andrew Dalke <dalke@…> Owned by: anonymous
Priority: normal Milestone:
Component: Documentation Version:
Severity: normal Keywords:
Cc:

Description

I'm upgrading from 0.8 to 0.9 preview

On the page  http://www.turbogears.com/preview/download/upgrade.html you link "ez_setup.py" to

 http://www.turbogears.com/preview/download/ez_setup.py

That returns with a

  The requested URL /preview/download/ez_setup.py was not found on this server.

I used the ez_setup from the 0.8 release.

Next I had problems with the following

[Andrew-Dalkes-Computer:/tmp/abc] dalke% sudo easy_install -f http://www.turbogears.org/preview/download/index.html --script-dir /usr/local/bin TurboGears
Searching for TurboGears
Best match: TurboGears 0.8.9
Processing TurboGears-0.8.9-py2.4.egg
TurboGears 0.8.9 is already the active version in easy-install.pth
Installing tg-admin script to /usr/local/bin

Using /usr/local/lib/python2.4/site-packages/TurboGears-0.8.9-py2.4.egg
Processing dependencies for TurboGears

and that was it - no upgrade.

Based on

 http://groups.google.ca/group/turbogears/browse_thread/thread/ba4a2b2666e4ca51/21936339a3752310

I first worked in a directory with nothing ("/tmp/abc" as you see) because in the thread Bob says to make sure that "setup.py" is not in the current directory or its subdirs.

That didn't work. I then used the "-U" ("upgrade") option as further suggested in the thread, as in

sudo easy_install -U -f http://www.turbogears.org/preview/download/index.html
   --script-dir /usr/local/bin TurboGears

That worked fine. You may want to update the docs to mention or include that flag.

Andrew <dalke@…>

Change History

comment:1 Changed 13 years ago by jorge.vargas

  • Status changed from new to closed
  • Resolution set to fixed

can't remenber date

Note: See TracTickets for help on using tickets.