Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #632 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

Protocol isn't maintained in redirects

Reported by: godoy Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

If you have a site in TG being accessed using HTTPS and you issue a turbogears.redirect then it will chop the 'HTTPS' part off of the URL and redirect you to an 'HTTP' URL. This might lead to some undesirable results and reduce user experience since she/he will have to fix the URL often.

Using relative URLs works fine and the problem is only with turbogears.redirect.

Change History

comment:1 Changed 13 years ago by godoy

  • Status changed from new to closed
  • Resolution set to fixed

I've added the following to config.py:

virtualHostFilter.on = True

and the missing ProxyPassReverse? to Apache and it worked. It doesn't work with Pound, though.

For Apache these are the required directives to proxy to TG:

ProxyPass / http://127.0.0.1:8080/
ProxyPassReverse / http://127.0.0.1:8080/

I'm not marking this as "invalid" just to make it easier for other people that try using Pound and see something like this.

Note: See TracTickets for help on using tickets.