Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #669 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

Unit tests for TurboGears users should not require sqlite

Reported by: kevin Owned by: anonymous
Priority: normal Milestone: 0.9a2
Component: TurboGears Version:
Severity: normal Keywords:
Cc:

Description

Testing TurboGears itself requires sqlite, because in-memory databases are the fastest and most convenient for testing. TurboGears users, on the other hand, should not have to have a functioning sqlite installation in order to run tests.

Change History

comment:1 Changed 11 years ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

It turns out that the real problem here was that there was specifically a database test included with the quickstart project. Since not all projects need to use a database, this test is not appropriate. It's been commented out in [1003].

Note: See TracTickets for help on using tickets.