Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #693 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

SelectionField has a variable called selected_attrs, but refers to self.selected_attr

Reported by: xentac Owned by: anonymous
Priority: normal Milestone:
Component: TG Widgets Version:
Severity: normal Keywords:
Cc:

Description

Someone renamed selected_attrs to selected_attr, but missed the class variable declaration.

Change History

comment:1 Changed 13 years ago by michele

No, selected_attr is not something like attrs but is used to pick the right term to use for a selected option, for example in a checkbox this is "checked", for a select field is "selected".

I agree that the name is less then ideal and I will correct selected_attrs to be selected_attr, maybe rename it to something less confusing and prefix it with an underscore.

comment:2 Changed 13 years ago by michele

  • Status changed from new to closed
  • Resolution set to fixed

Done in r1046, thanks for signaling this. ;-)

Note: See TracTickets for help on using tickets.