Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #704 (closed defect: invalid)

Opened 13 years ago

Last modified 12 years ago

quickstart readme has wrong script name

Reported by: efm-turbogears@… Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version:
Severity: trivial Keywords:
Cc:

Description

root/trunk/turbogears/qstemplates/quickstart/README.txt_tmpl has "start-PROJECTNAME.py script" it should be "PROJECTNAME-start.py script"

Change History

comment:1 Changed 13 years ago by godoy

  • Component changed from CherryPy to TurboGears
  • Severity changed from major to trivial

No, it shouldn't. The startup script is named "start-projectname.py". And this is so to avoid problem for those who use tab completion on their shells. It was discussed at the mailing list (you can find the discussion in the archives).

I'd close this ticket...

comment:2 Changed 13 years ago by anonymous

Have you done a test? I did a fresh install today, and ran into this problem.

Perhaps the other change was never done.

comment:3 Changed 13 years ago by godoy

It was done and it is working. What version did you install?

godoy@jupiter ~/tmp % tg-admin quickstart
Enter project name: testapp
Enter package name [testapp]: 
Selected and implied templates:
  TurboGears#tgbase      tg base template
  TurboGears#turbogears  web framework
(...)

godoy@jupiter ~/tmp % cd testapp 
godoy@jupiter ~/tmp/testapp % l
total 24
drwxr-xr-x  4 godoy users  272 2006-04-01 01:05 ./
drwxr-xr-x  3 godoy users   72 2006-04-01 01:05 ../
-rw-r--r--  1 godoy users 1050 2006-04-01 01:05 dev.cfg
-rw-r--r--  1 godoy users 1215 2006-04-01 01:05 prod.cfg
-rw-r--r--  1 godoy users  124 2006-04-01 01:05 README.txt
-rw-r--r--  1 godoy users 1983 2006-04-01 01:05 setup.py
-rw-r--r--  1 godoy users  978 2006-04-01 01:05 setup.pyc
-rwxr--r--  1 godoy users  817 2006-04-01 01:05 start-testapp.py*
drwxr-xr-x  7 godoy users  312 2006-04-01 01:05 testapp/
drwxr-xr-x  2 godoy users  272 2006-04-01 01:05 testapp.egg-info/

comment:4 Changed 13 years ago by anonymous

I downloaded ez_setup.py 0.6a10 from  http://www.turbogears.org/download/nix.html, and used that to bootstrap the install.

comment:5 Changed 13 years ago by godoy

You check versions with "tg-admin info".

Here this bug is fixed (and has been for a while, before releasing 0.9a2, IIRC):

% tg-admin info
TurboGears 0.9a3dev-r1050
nose 0.8.4
RuleDispatch 0.5a0
setuptools 0.6a11
FormEncode 0.4
cElementTree 1.0.5-20051216
PasteScript 0.5
elementtree 1.2.6
simplejson 1.1
SQLObject 0.7.1dev-r1675
CherryPy 2.2.0rc1
TurboKid 0.9.3dev-r1040
TurboJson 0.9.0
PyProtocols 1.0a0
Cheetah 1.0
PasteDeploy 0.3
Paste 0.5
FormEncode 0.4
kid 0.9
elementtree 1.2.6

I still believe this should be closed since it looks like you're working on an old version of TG.

comment:6 Changed 13 years ago by godoy

I meant "before 0.9a1".

comment:7 Changed 13 years ago by anonymous

I'm running TurboGears 0.8.9 command line interface.

I don't know why ez_setup.py pulled that version. Close it, there's something broken someplace I don't understand or care about.

comment:8 Changed 13 years ago by godoy

  • Status changed from new to closed
  • Resolution set to invalid

Check if you don't have an older version installed before in your path. The version that appears first will be used...

comment:9 Changed 13 years ago by anonymous

which tg-admin /usr/local/bin/tg-admin [efm@gwen TurboGears]$ locate tg-admin /usr/local/bin/tg-admin [efm@gwen TurboGears]$ ls -l /usr/local/bin/tg-admin -rwxr-xr-x 1 root root 272 Mar 31 16:21 /usr/local/bin/tg-admin

So, I only have one tg-admin, and it was installed yesterday, and it was the wrong version. Are you sure ez_setup.py does the right thing?

Note: See TracTickets for help on using tickets.