Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #712 (closed defect: wontfix)

Opened 13 years ago

Last modified 12 years ago

Using tg-admin in 0.9 on projects started in 0.8 gives weird error

Reported by: arnarbi@… Owned by: anonymous
Priority: normal Milestone: 0.9
Component: TurboGears Version: 0.9a1
Severity: normal Keywords:
Cc:

Description

When running tg-admin whatever on projects started with 0.8, the following error occurs:

Traceback (most recent call last):
  File "/usr/bin/tg-admin", line 7, in ?
    sys.exit(
  File "/usr/lib/python2.4/site-packages/TurboGears-0.9a2-py2.4.egg/turbogears/command/base.py", line 261, in main
    command.run()
  File "/usr/lib/python2.4/site-packages/TurboGears-0.9a2-py2.4.egg/turbogears/command/base.py", line 164, in run
    self.find_config()
  File "/usr/lib/python2.4/site-packages/TurboGears-0.9a2-py2.4.egg/turbogears/command/base.py", line 54, in find_config
    load_project_config(self.config)
  File "/usr/lib/python2.4/site-packages/TurboGears-0.9a2-py2.4.egg/turbogears/command/base.py", line 40, in load_project_config
    modulename = package + ".config.app")
  File "/usr/lib/python2.4/site-packages/TurboGears-0.9a2-py2.4.egg/turbogears/config.py", line 30, in update_config
    modfile = pkg_resources.resource_filename(packagename, modname + ".cfg")
  File "/usr/lib/python2.4/site-packages/setuptools-0.6a11-py2.4.egg/pkg_resources.py", line 799, in resource_filename
    return get_provider(package_or_requirement).get_resource_filename(
  File "/usr/lib/python2.4/site-packages/setuptools-0.6a11-py2.4.egg/pkg_resources.py", line 119, in get_provider
    __import__(moduleOrReq)
ImportError: No module named config

The errors is probably normal, but could be less cryptic.

Change History

comment:1 Changed 13 years ago by kevin.horn AT gmail DOT com

If I am not mistaken, this is due to the config system changing between 0.8 and 0.9.

This issue can be resolved by following the upgrade instructions here:  http://www.turbogears.org/preview/download/upgrade.html

Yes, the error message could be a little more helpful.

This ticket should probably be closed unless someone wants to do something about the error message to make it a little more friendly.

comment:2 Changed 13 years ago by arnarbi at gmail

This bug was filed on the request of Kevin Dangoor. Please see  http://groups.google.com/group/turbogears/browse_thread/thread/9ede58489d3d535/5c83f2c8d5441eb6 for reference.

comment:3 Changed 13 years ago by kevin.horn AT gmail DOT com

sorry...my bad :)

comment:4 Changed 13 years ago by fredlin

  • Status changed from new to closed
  • Resolution set to wontfix

outdated entry :P

Note: See TracTickets for help on using tickets.