Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #724 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

Turn of automatic "svn add" behavior in quickstart

Reported by: kevin Owned by: anonymous
Priority: normal Milestone: 0.9a5
Component: TurboGears Version: 0.9a4
Severity: normal Keywords:
Cc:

Description

PasteScript 0.5.1 adds a switch to turn off automatic "svn add"s of files. tg-admin quickstart should use this. (First step: upgrade to PasteScript 0.5.1... change the requirement in setup.py, change the svn:external). I believe there are a couple of tickets that this change will close.

Change History

comment:1 Changed 13 years ago by michele

Tickets:

#651, #557

comment:2 Changed 13 years ago by alberto

  • Status changed from new to closed
  • Resolution set to fixed

I've bumped PasteScript to 0.5.1 in [1213]. However, I don't seem to find the switch you're talking about in create_distro.CreateDistroCommand?. A svn_repository option seems to be there but it's not on by default (maybe this is the change form 0.5 to 0.5.1?) and not touched by quicstart.

I've tried to reproduce the problem by "tg-admin quickstart"ing an empry project inside a svn sandbox as the tickets described and nothing was automatically added to the repository.

I guess it's safe to close the ticket. Please feel free to reopen if I've missed anything.

Alberto

P.S. Leaving the two tickets mentioned above open until someone reviews this in case I screwed up. :)

Note: See TracTickets for help on using tickets.