Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #766 (closed defect: duplicate)

Opened 13 years ago

Last modified 12 years ago

SQLObject can't create schema for 'complex' joins

Reported by: jvanasco@… Owned by: anonymous
Priority: normal Milestone:
Component: SQLObject Version: 0.9a4
Severity: major Keywords:
Cc:

Description

SQLObject seems to have issues with higher relational joins ( 2nf seems ok, but i haven't gotten it to work with 3NF yet)

After hours of googling, I landed on this:  http://joe.sl4g.com/words/code/sqlobject_order.html

There's no real 'fix' to it, but including that documentation into TG itself where people can find it would pretty much solve the issue.

I'm saying that its major, because I until i came across that link, I had an exceedingly poor view of Turbogears - and I can't help but think that a lot of people before me have probably encounted it too and just gone with Django or Rails.

Change History

comment:1 Changed 13 years ago by godoy

It was answered more than once on the mailing list as well, so searching the archives should reveal that... I believe that this is an exception and only occurs on more complex models.

Probably this kind of thing won't happen with SQL Alchemy, which is gaining support for the next versions.

The fix, IMHO, should be some pointer to that in the docs (it should also cover the case of separate model files since the solution is the same...).

I wouldn't classify this as "major" because it only happens in complex models and there are people able to answer that on the mailing list (besides the archives there).

comment:2 Changed 13 years ago by godoy

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as a duplicate of #279.

comment:3 Changed 13 years ago by anonymous

"The fix, IMHO, should be some pointer to that in the docs (it should also cover the case of separate model files since the solution is the same...)."

I'm in total agreement. It didn't come up on most queries to google or google groups though - I think mostly because you have to know what the issue is to find it. Pointing to it the external article or the Trac ticket in the docs completely solves the problem.

Note: See TracTickets for help on using tickets.