Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #789 (closed defect: invalid)

Opened 13 years ago

Last modified 12 years ago

mysqldb aka mysql-python broken on windows

Reported by: jorge.vargas Owned by: anonymous
Priority: normal Milestone: 0.9a5
Component: SQLObject Version: 0.9a4
Severity: major Keywords:
Cc:

Description

This is because the author of mysqldb is NOT shipping binary windows packages anymore therefore someone will have to make a installer. Last version is 1.2.1 which doesn't has a windows installer and it's broken from easy_install.

With this and #763, I think we are very badly shape on the Windows platform, we have the most used and the most simple database broken and they are both at SQLObject level.

Change History

comment:1 Changed 13 years ago by jorge.vargas

sorry for the double post.

Best part of it is the error message error: Setup script exited with error: The .NET Framework SDK needs to be installed before building extensions for Python.

so looking at it from a user perspective you are asking ME to install .NET to work on a python framework!

comment:2 Changed 13 years ago by godoy

I don't see how is this a TG or SQL Object bug at all. I'm sorry, but I'm willing to close this as "invalid" since there's nothing related to TG here -- except that MySQL can be used as a database server among other equally free (and IMNSHO better) alternatives.

comment:3 Changed 13 years ago by godoy

I was checking some old notes and I don't know how relevant they are, but IIRC this is due to the fact that the binary release of Python was built with this compiler. It is related to binary object mapping and linking.

If you've built your Windows version of Python with MinGW or CygWin? then you'd see a different requirement. The problem is that there are some standard C stuff missing from Windows and they are implemented by each compiler, sacrificing binary compatibility.

Anyway, this is from old messages I had here. Things might have changed...

comment:5 Changed 13 years ago by kevin

  • Status changed from new to closed
  • Resolution set to invalid

While I agree that poor MySQL support on Windows is a problem that we can endeavor to fix by building eggs, I am going to close this ticket because I haven't yet spread TurboGears' boundaries out that far.

Note: See TracTickets for help on using tickets.