Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #815 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

Logging errors when starting the toolbox outside a TG project

Reported by: michele Owned by: anonymous
Priority: normal Milestone:
Component: Toolbox Version: 0.9a5
Severity: minor Keywords:
Cc:

Description

Run the toolbox from any directory that's not a valid TG project and that's what you get in the console output:

config file prod.cfg not found or is not a file.
2006-05-02 14:09:28,029 cherrypy.msg INFO HTTP: Serving HTTP on http://localhost :7654/
2006-05-02 14:09:28,275 turbokid.kidsupport DEBUG Compiling template for turboge ars.view.templates.sitetemplate
2006-05-02 14:09:28,276 turbokid.kidsupport DEBUG Compiling template for turboge ars.toolbox.main
2006-05-02 14:09:28,277 turbokid.kidsupport DEBUG Applying template turbogears.t oolbox.main
Traceback (most recent call last):
  File "/usr/lib/python2.4/logging/__init__.py", line 737, in emit
    self.stream.write(fs % msg)
AttributeError: 'str' object has no attribute 'write'

Change History

comment:1 Changed 13 years ago by roger.demetrescu

Hi Michelle,

Couldn't reproduce it with my r1349...

E:\nothing_here>tg-admin toolbox
config file prod.cfg not found or is not a file.
2006-05-02 22:37:00,000 cherrypy.msg INFO HTTP: Serving HTTP on http://localhost:7654/
2006-05-02 22:37:00,217 turbokid.kidsupport DEBUG Compiling template for turbogears.view.templates.sitetemplate
2006-05-02 22:37:00,217 turbokid.kidsupport DEBUG Compiling template for turbogears.toolbox.main
2006-05-02 22:37:00,217 turbokid.kidsupport DEBUG Applying template turbogears.toolbox.main
127.0.0.1 - - "GET / HTTP/1.1" 200 5209 "" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2"

Here is my info:

TurboGears 1.1a0dev-r1349
nose 0.8.6
configobj 4.3.0
ruledispatch 0.5a0.dev-r2115
setuptools 0.6a11
formencode 0.5.1
celementtree 1.0.5-20051216
pastescript 0.5.1
elementtree 1.2.6
simplejson 1.3
sqlobject 0.7.1dev-r1675
cherrypy 2.2.1
turbokid 0.9.5
turbojson 0.9.2
pyprotocols 1.0a0dev-r2082
cheetah 1.0
pastedeploy 0.5
paste 0.5
formencode 0.5.1
kid 0.9.1
elementtree 1.2.6

Am I missing something ? Did you turn on any configuration ?

Cheers

comment:2 Changed 13 years ago by michele

  • Status changed from new to closed
  • Resolution set to fixed

Fixed, dunno when! ;-)

Note: See TracTickets for help on using tickets.