Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #835 (closed defect: fixed)

Opened 12 years ago

Last modified 10 years ago

Installation (and Update) of RuleDispatch-0.5a0.dev-r2115 fails on Mac OS X 10.4.6

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 1.0b1
Component: Installation Version: 0.9a5
Severity: normal Keywords:
Cc: lateef.jackson@…, kevin

Description

Hardware::

17" Powerbook

Software::

Mac OS X 10.4.6 with working developer tools

Problem::

Can't compile "src/dispatch/_speedups.c"

Possible Reason::

Using wrong paths for the compiler ...

Compiler output::

In file included from src/dispatch/_speedups.c:3:
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:18:20: error: limits.h: No such file or directory
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:21:2: error: #error "Something's broken.  UCHAR_MAX should be defined in limits.h."
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:25:2: error: #error "Python's source code assumes C's unsigned char is an 8-bit type."
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:32:19: error: stdio.h: No such file or directory
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:34:5: error: #error "Python.h requires that stdio.h define NULL."
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:37:20: error: string.h: No such file or directory
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:38:19: error: errno.h: No such file or directory
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:39:20: error: stdlib.h: No such file or directory
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:41:20: error: unistd.h: No such file or directory
/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4/Python.h:53:20: error: assert.h: No such file or directory

The files are all in /usr/include ...

Additional Info::

Attachments

RuleDispatch-0.5a0.dev_r2115-py2.4-macosx-10.4-fat.egg Download (235.0 KB) - added by anonymous 11 years ago.

Change History

comment:1 Changed 12 years ago by kevin

Which version of gcc are you using? AFAIK, you need to be using 3.3 (sudo gcc_select 3.3). I don't *think* anything in changed in the RuleDispatch? we're distributing between 0.9a4 and 0.9a5. Additionally, the egg should include the binary so there shouldn't be compilation happening as is.

comment:2 Changed 12 years ago by kevin

  • Milestone changed from 0.9a6 to 1.0b1

comment:3 Changed 12 years ago by anonymous

I tried with both gcc versions (3.3 and 4.0) ... same error ... The binary *is* in the egg ...

Now I'm searching the answers to 4 questions:

  1. Why is the binary file not found ?
  2. Where does the compile error come from ?
  3. Is there a way to install RuleDispatch manually ?
  4. How can I debug the installation of an egg ?

(The answer to question 3 could be a workaround ... The answer to question 4 could help to find an answer to questions 1 and 2 ...)

comment:4 Changed 12 years ago by anonymous

I just found another piece of information:

There are two files:

This file contains the source code

This file contains the binary

It seems that only the first of these two files is downloaded ... since the binary file is in the second, it is never found ... (And I found the answer to question 1 ...)

comment:5 Changed 12 years ago by anonymous

I just tried again with milestone:0.9a6 ... no changes ...

easy_install still starts installing the RuleDispatch?-Package by downloading the sources (RuleDispatch?-0.5a0.dev-r2115.tar.gz) and fails compiling _speedups.c

comment:6 Changed 11 years ago by anonymous

  • Cc lateef.jackson@… added

Good news ... I found a solution ...

(Since there is a duplicate (#897) I added the reporter as CC ...)

I use an universal binary of python ... so it seem logical that I can't use a pure PPC version of the RuleDispatch egg ... I think that's the reason why the binary egg isn't used (It's for PPC only ...)

And for compiling binary python extensions a simple PPC SDK can't be used, only an Universal Binary SDK ...

Take a look at  this page for more information.

I downloaded version 2.3 of apples developer tools (915MB ...), installed them (including the needed universal SDK) and tried to install TurboGears 0.9a6 ... Installation completed successfully !!'''

BTW: Compiling with GCC4 works with warnings ... Compilation with GCC3 fails (some problems with the used command line parameters)

Now I can start testing TurboGears with RuleDispatch?-0.5a0.dev_r2115-py2.4-macosx-10.4-fat.egg (and cElementTree-1.0.5_20051216-py2.4-macosx-10.4-fat.egg) ...

comment:7 Changed 11 years ago by godoy

  • Cc kevin added

That's nice! And too bad that there's almost 1G to download... Can't you provide those "fat-eggs" to Kevin to make them available for other people on the website? :-)

By the way, what is a "fat.egg"? An egg with high level of colestherol? :-) (BAD joke... Sorry)

Changed 11 years ago by anonymous

comment:8 Changed 11 years ago by anonymous

I just added the fat.egg ...

It's the frist egg I build from source, so just try it and tell me if it works ...

comment:9 Changed 11 years ago by anonymous

BTW, you'll also need the fat.eggs for

  • PyProtocols (PyProtocols?-1.0a0-py2.4-macosx-10.4-fat.egg)
  • cElementTree (cElementTree-1.0.5_20051216-py2.4-macosx-10.4-fat.egg)

I build the first one (from source), but failed for the second (don't know why ...)

Is it possible to use the eggs created during the installation of TurboGears on other maschines ?

comment:10 Changed 11 years ago by jorge.vargas

is there a way to have this distintion between macs on setuptools? right now the ruledispatcher dep is the less restrictive of all

comment:11 Changed 11 years ago by elvelind

basicly, we need somebody that can build eggs for the universal/intel mac platform. If somebody are running this platform and are willing to help out please send me a mail.

comment:12 Changed 11 years ago by elvelind

  • Status changed from new to closed
  • Resolution set to fixed

thanks to alberto we now have universal/fat eggs.

Note: See TracTickets for help on using tickets.