Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #878 (closed task: fixed)

Opened 13 years ago

Last modified 12 years ago

Make TurboGears more system package friendly.

Reported by: kevin Owned by: kevin
Priority: highest Milestone:
Component: Web site Version: 1.0b1
Severity: major Keywords:
Cc:

Description

1) remove thirdparty packages from the TG tarball (I'd like to do this
anyhow... I'm considering eliminating the svn:externals and adding a
little script to let people easily grab the desired version).

2) Make all of the third party tarballs available on the TG download page

3) split out turbocheetah, turbojson and turbokid into their own svn
trees (with tags/branches/trunk)

Change History

comment:1 Changed 13 years ago by kevin

  • Milestone set to 1.0

comment:2 Changed 13 years ago by jorge.vargas

  • Priority changed from normal to highest
  • Severity changed from normal to major

for mayor exposure we need this done soon. therefore I'm upping it's priorities.

comment:3 Changed 13 years ago by jtate

There are still not enough tarballs available to build TurboGears 1.0b1.

comment:4 Changed 13 years ago by jtate

The necessary tarballs (not provided on cheese shop, or sourceforge or elsewhere) that I've discovered so far are

  • SQLObject (provided)
  • TurboKid? (available on cheeseshop, but not the right version)
  • TurboJson? (available on cheeseshop, but not the right version)

comment:5 Changed 13 years ago by jtate

continued:

  • TurboCheetah? is on cheeseshop
  • TGFastData (Not on cheeseshop or turbogears.org)

comment:6 Changed 13 years ago by alberto

  • Milestone changed from 1.0 to 1.1

comment:7 Changed 12 years ago by jorge.vargas

  • Version 0.9a5 deleted
  • Component changed from TurboGears to website
  • Milestone 1.1 deleted

Elvelind, Lee how has access to the cheeseshop accounts? could you guys take care of this.

comment:8 Changed 12 years ago by zlgdgzl

Spam comment deleted

comment:9 Changed 12 years ago by Chris Arndt

  • Status changed from new to closed
  • Version set to 1.0b1
  • Resolution set to fixed

TurboKid? and TurboJson? tarballs are on the Cheesehop now in their latest version. TGFastData is not necessary to build TurboGears. Closing this ticket.

TGFastData needs a new realease. This will go into a new ticket.

Note: See TracTickets for help on using tickets.