Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #890 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

[PATCH] You get a TypeException in the paginate decorator when set allow_limit_override to True

Reported by: pfrantz@… Owned by: anonymous
Priority: normal Milestone:
Component: TurboGears Version: 0.9a6
Severity: normal Keywords:
Cc:

Description

Using allow_limit_override=True in the paginate decorator causes a Type exception to occur when you move to another page. This is caused by the tg_paginate_limit not being converted to an int.

Attachments

paginate.diff Download (552 bytes) - added by pfrantz@… 13 years ago.
A diff file with the appropriate line fix.

Change History

Changed 13 years ago by pfrantz@…

A diff file with the appropriate line fix.

comment:1 Changed 13 years ago by roger.demetrescu

  • Summary changed from You get a TypeException in the paginate decorator when set allow_limit_override to True to [PATCH] You get a TypeException in the paginate decorator when set allow_limit_override to True

making it visible to "Pending Patches" report

comment:2 Changed 13 years ago by kevin

  • Status changed from new to closed
  • Resolution set to fixed

committed in [1627]. Thanks!

Note: See TracTickets for help on using tickets.