Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #905 (closed defect: fixed)

Opened 13 years ago

Last modified 12 years ago

[PATCH] Support checkbox and radio input fields in remoteFormRequest

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 1.0b1
Component: TurboGears Version: 0.9a6
Severity: major Keywords:
Cc:

Description

In the turbogears/widgets/static/ajax.js, remoteFormRequest does not play nicely with submitting values from CheckBoxList widgets.

The problem is, all of the checkboxes have the same name, but only the last value is honored due to use of a dictionary-style array. Additionally, the "checked" attribute is not honored.

 detail and diffs in this thread

Change History

comment:1 Changed 13 years ago by roger.demetrescu

  • Summary changed from Support checkbox and radio input fields in remoteFormRequest to [PATCH] Support checkbox and radio input fields in remoteFormRequest

Just making this ticket visible in "Pending Patches" report

comment:2 Changed 13 years ago by alberto

How about leveraging Mochikit's functionallity which is already bundled in TG?

formContents(elem):

Search the DOM tree, starting at elem, for any elements with a name and value attribute. Return a 2-element Array of names and values suitable for use with MochiKit.Base.queryString.

comment:3 Changed 13 years ago by alberto

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [1738]

Note: See TracTickets for help on using tickets.