Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Ticket #915 (closed defect: wontfix)

Opened 13 years ago

Last modified 12 years ago

layout_params cannot use python variables

Reported by: doug@… Owned by: anonymous
Priority: normal Milestone: 1.5
Component: Kid Version: 0.9a6
Severity: normal Keywords:
Cc:

Description

Having had a quick dig through the code, I think this is a TG problem, not a Kid problem.

What I want is to use passed-in python variables in layout_params, e.g.:

<!DOCTYPE ..>
<?python
layout_params['foo'] = bar # bar passed in by controller
?>
<html>

However it barfs if I do this. It looks like the problem is in the template importing - anything in a <?python ... ?> block before <html> is evaluated on import, and because the variables are not available there, it blows up. Using these variables after the html tag is fine.

Change History

comment:1 Changed 13 years ago by jorge.vargas

  • Milestone set to 1.0b2

also check this, i believe that feature is going to be deleted

 http://www.mail-archive.com/kid-template-discuss@lists.sourceforge.net/msg00381.html

comment:2 Changed 13 years ago by alberto

  • Milestone changed from 1.0b2 to 1.1

comment:3 Changed 12 years ago by jorge.vargas

  • Status changed from new to closed
  • Resolution set to wontfix

why not use the way TG does this? isn't that the goal of integrating with CP and our enhanced @expose

Note: See TracTickets for help on using tickets.