Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Changes between Version 32 and Version 33 of 2.0/changelog


Ignore:
Timestamp:
12/13/08 10:54:24 (10 years ago)
Author:
Gustavo
Comment:

updated 2.0b1

Legend:

Unmodified
Added
Removed
Modified
  • 2.0/changelog

    v32 v33  
    11= Change Log = 
    22 
    3 == 1.9.7b3 (**unreleased**): == 
     3== 2.0b1 (**unreleased**): == 
    44 
    55=== Features === 
     
    77 
    88=== Fixes === 
    9  *  
     9 * Failing tests in tg2 trunk (#2059). 
     10 * Can't use @require decorator and require property in the same controller (#2063). 
    1011 
    1112=== Contributors (in alphabetic order) === 
     
    1314 
    1415=== Upgrading from 1.9.7b2 === 
    15 Nothing is required. It's backwards compatible. 
     16 * Because of #2063, if you are using the controller-wide authorization functionality, you have to rename the "require" attribute to "_require". For example: 
     17{{{ 
     18    class SomeSecureController(BaseController): 
     19        _require = predicates.has_permission('onePermission') 
     20 
     21        @expose('my_package.template.index') 
     22        def index(self): 
     23            # do something here 
     24 
     25        @expose('my_package.template.add') 
     26        @authorize.require(predicates.has_permission('specialPerm')) 
     27        def do_things(self, **kw): 
     28            # do other things here 
     29}}} 
     30 
    1631 
    1732=== Known Issues ===