Warning: Can't synchronize with repository "(default)" (Unsupported version control system "svn": No module named svn). Look in the Trac log for more information.

Changes between Version 33 and Version 34 of 2.0/changelog


Ignore:
Timestamp:
12/14/08 17:26:20 (10 years ago)
Author:
mramm
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • 2.0/changelog

    v33 v34  
    1010 * Can't use @require decorator and require property in the same controller (#2063). 
    1111 
    12 === Contributors (in alphabetic order) === 
    13 Gustavo Narea, Mark Ramm 
     12=== Backwards Incompatible Changes === 
     13 
     14=== Contributors (in alphabetic order) === 
     15Florent Aide, Jonathan Gustavo Narea, Mark Ramm, Jorge Vargas 
    1416 
    1517=== Upgrading from 1.9.7b2 === 
    16  * Because of #2063, if you are using the controller-wide authorization functionality, you have to rename the "require" attribute to "_require". For example: 
     18 * Because of #2063, if you are using the controller-wide authorization functionality, you have to rename the "require" attribute to "alow_only". For example: 
    1719{{{ 
    1820    class SomeSecureController(BaseController): 
     
    2931}}} 
    3032 
    31  
    32 === Known Issues === 
    33    * Toscawidgets does not render js_callbacks properly because of breakage from the simplejson. 
    34  
     33If you are using tg.cycle, tg.selector, tg.ipeek, or tg.checker in your templates, you'll have to add that functionality to your lib.helpers module and import it from there.  There is some talk about asking for some of these things to be added to webhelpers, so if you use them you may want to chime in in support of that on the mailing list.  
     34 
     35   
    3536== 1.9.7b2 (October 29th, 2008): == 
    3637